Welcome to OrchidsForum.com. We are a friendly online community for Orchid Growers all over the world. If you haven't joined yet we invite you to register and join our community. Hope to see you on our forums!

Infected schomburgkia rosea???

Discussion in 'Issues, Disease and Pests' started by Russell, Aug 31, 2021.

  1. Russell

    Russell New Member

    Messages:
    19
    Likes Received:
    13
    Is this Schomburgkia rosea infected with a virus, theres a slight discolouration in the new leaf, like Loss of pigmentation in that area.

    First two pictures show the older leaves with no discoloration IMG_20210831_171941.jpg IMG_20210831_172035.jpg
    IMG_20210831_172003.jpg IMG_20210831_171925.jpg IMG_20210831_172007.jpg
     
    Sabinchen likes this.
  2. Sabinchen

    Sabinchen Well-Known Member

    Messages:
    272
    Likes Received:
    272
    It is not sure Russel. It could also just be a missing of minerals.
    I saw plants they looked very healthy and had a Virus. And other looked very ill. Mostly you saw it at a flower when collor is breaking. Or you test it. I am testing at the moment 50 new plants. I found 2, but the one have black sunken spots, and the other color breaking in the flowers.
     
  3. Russell

    Russell New Member

    Messages:
    19
    Likes Received:
    13
    Thanks, I started using a fertiliser last week, hope the patchs dissappear.
    Quite hard to find the relevant fertilisers and other chemicals after certain chemicals were restricted.
     
    Sabinchen likes this.